
 
 
 

FileMaker Pro 7.0: Basics 
Learning Guide 
 
 
 Database Basics 

A database, at its very core, is simply a structured collection of 
data.  Access sees your data in the form of a table that is composed 
of rows and columns.  Each of these rows is a record in your 
database, containing all data about a single object, person, or 
concept.   
 
The sample table below captures information about CDs in an 
individual’s music collection.  The record displayed in the second 
row contains information about Blue Moon Swamp, a CD released 
in 1997 by John Fogerty. 

 
Tracking  Artist Album Name Released Location 
1 Farm Dogs Immigrant Sons 1998 Home 
2 John Fogerty Blue Moon Swamp 1997 Car 
3 Barenaked Ladies Stunt 1998 Office 
4 CPR CPR 1998 Home 
5 Elton John  Tumbleweed Connection 1971 Home 
6 Sting Bring on the Night 1985 Car 
7 Fleetwood Mac Rumours 1977 Home 
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Every record is composed of fields, each contains a specific type of 
data (numbers, text, currency, dates, etc.).  Each field is 
represented as a column in a data table, because the field is present 
in each record in the database.  In this case, the Album Name field 
(shaded below) is a text field. 
 

Tracking  Artist Album Name Released Location 
1 Farm Dogs Immigrant Sons 1998 Home 
2 John Fogerty Blue Moon Swamp 1997 Car 
3 Barenaked Ladies Stunt 1998 Office 
4 CPR CPR 1998 Home 
5 Elton John  Tumbleweed Connection 1971 Home 
6 Sting Bring on the Night 1985 Car 
7 Fleetwood Mac Rumours 1977 Home 

 



Once this structure is in place, you can access your data using 
different layouts to provide a greater level of flexibility in the 
display and organization of your data.  For example, you can enter 
data using forms, or create reports to present your data. 
 
 
 
Exploring the FileMaker interface 
The image below identifies the basic elements of FileMaker’s 
interface.  Each will be described in detail on the pages to follow. 
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Elements of the FileMaker window 
In addition to the standard elements in Windows XP, FileMaker 
uses several graphic elements to provide its users with access to 
the data in a database as well as some basic commands. 
 
The FileMaker Toolbar 
The FileMaker toolbar allows you to access many of the basic 
commands for working data in your databases. 
 

 
 
To … Click on the button… That looks like… 

Create a new database New   

Open an existing database Open   

Print records Print   

Add a record New Record  

Create a copy of a record Duplicate Record  

Delete a record Delete Record  

Sort records Sort  
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Status Area 
The status area, located at the left edge of the FileMaker window, 
mallows you to browse database records and select layouts with 
which to display data. 
 

 
 

 
 

The Book Tool 
The Book tool, located in the middle of the status area, provides 
browsing access to the records within a database.  To display the 
next record in the database, click on the right page on the Book 
icon.   
• To display the previous record, click on the left page.  
• To jump between records, use the switch directly below the 

book. 
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Tip: Using the Book tool in other modes 
The Book tool can be used to move between various items, 
depending upon what mode you are in. It is a control for moving 
from one record to another in Browse mode, from one layout to 
another in Layout mode, from one find request to another in Find 
mode, and from one page to another in Preview mode. 

 
The Layout Drop Menu 
The Layout drop menu, located above the Book icon, allows you to 
access any of the layouts you created. To switch between layouts: 
• Click on the right facing arrow of the Layout Drop Menu. 
• Click on the name of the layout you wish to view. 
 

 
 
 
 

The Mode Pop-up Menu 
The Mode pop-up menu, located at the bottom left of the 
FileMaker window, allows you to switch between modes: 
 
The mode … Allows you to … 
Browse Enter and retrieve data 
Find Search the database 
Layout Create custom layouts 
Preview  Preview a layout 

 
• To switch modes, click on the down facing arrow of the Mode 

Pop-up Menu. 
• From the list that appears, select the mode you wish to view. 
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Magnification buttons 
These Magnification buttons, located in the bottom left corner of 
the FileMaker window, allow you to view your database at greater 
or lesser magnification.   
• To zoom in on your data layout, click on the right-hand button.  
• To zoom out, click on the middle button.   
• Clicking on the button labeled 100 will return the layout to 

normal magnification. 
 

 
 

 
Status Area Toggle Button 
The Status Are toggle button, located in the bottom left corner of 
the FileMaker window, allows you to hide and restore the Status 
Area.   
• To hide the Status Area, clicking on the Status Area toggle 

button. 
 

 
 
• To restore the status area, click a second time on the Status 

Area toggle button.  
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FileMaker Views 
FileMaker Pro offers 3 different ways to view the data in your 
database.  You can swap between views at will by selecting your 
desired view from the View menu.  Bear in mind that these views 
are merely different ways of displaying data – the data in your 
database will not be changed when it is displayed in a different 
view. 
 

 
Tip: Note that in the List view the length of your layout will 
determine how many records may be displayed on the screen at 
one time; shorter layouts will permit the display of more records. 
 

View  Description 

Form Displays a single record on the screen at a time, 
using the selected layout. 

List Displays multiple records on the screen at a time, 
using the selected layout.  

Table 
Displays your data in a table format, using one row 
to represent one record. Each field is represented as 
a column in the table 
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Creating a new database 
• From the File menu, select New Database. 
• The Create New File window will appear. 
• Navigate to the folder where you wish to save your new 

database.   
• In the File name box, type a name for the database.   
• Click on the button labeled Save. 
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Adding tables 
Use database tables to organize and group your data by a common 
or characteristic principle. Your data base can contain as many 
tables as you need to organize your data. By default, a new file 
contains a table with the same name as the file. To define a table: 
• Open the database to which you wish to add tables. 
• From the File menu, select Define. 
• From the menu that appears, select Database. 
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• The Define Database window will appear. 
 

 
 

• Click on the tab labeled Tables. 
• In the box labeled Table Name, type a name for your new 

table. 
• Click on the button labeled Create. 
 

 
 

• Continue to define tables as described above. 
• Once all the desired tables have been defined you may: 

o Click the button labeled OK to return to the Filemaker 
window, or 

o Click on the tab labeled Fields to define the fields in your 
new tables. 
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Defining fields for your database 
After creating a database or adding new tables, define the fields 
that will capture your data. 
• In the Define Database window, select the Fields tab. 
• In the box labeled Field Name type the name of the new field. 
• From the pull-down menu next to the box labeled Field Name, 

select the type of data you wish to store. 
• Click on the button labeled Create to add the new field to the 

database. 
 

 
 

To define a second field:  
• Type the name of the new field. 
• Select its type. 
• Click on the button labeled Create or type Enter on your 

keyboard. 
• Define additional fields using these steps. 
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• To change the name or data type of an existing field before 
entering data: 

o Click on the field’s name in the field list. 
o Once the field name is highlighted in blue, make 

changes to the type and field name. 
o Click on the button labeled Change to finalize the 

changes to the field. 
 

 
 
• When you have finished defining your fields, click on the 

button labeled OK. 
• FileMaker will automatically create an initial blank record in 

your database and make the first field in the record active for 
data entry. 

 
• The following table displays descriptions of various field types: 

Field Type Field Content Restrictions 
Text Text of any kind Limited to 64,000 characters 
Number Numeric content Limited to 255 characters; must be on 

one line 
Date Full date in various 

formats 
Single date between year 1 and year 
5000; limited to 8 characters (month, 
day, year, separators) 

Time Clock time One time; limited to 8 characters 
Container Image, movie, sound, 

or linked object 
Limited to one item per container field

Calculation Result of a formula-
based calculation 

Limited to one formula with a text, 
numeric, date, time, or container 
result 

Summary Summation of fields 
in several records 

Result of a single summary function 
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 Creating relationships 
A relationship is a powerful method for organizing your data. 
Using a relationship, you can join data in one or more tables based 
on common field values, different field values, or a comparison of 
values in two or more fields. To create a relationship between 
tables: 
• From the File menu, select Define. 
• From the menu that appears, select Database. 
• The Define Database window will appear. 
• Click on the tab labeled Relationships. 
 

 
 
• The Relationships Graph will be displayed in the Define 

Database window. 
• To create a relationship: 

o Locate the two tables you will be using for the 
relationship. 

o Click on a match field in one of the tables and drag to 
the corresponding match field in the other table. 
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o A relationship will be created between the two tables. 
 

 
 

o Repeat the previous steps until all the desired 
relationships have been created. 

• Click on the button labeled OK. 
 

 
 
 
Tip: When creating a relationship between two tables in the 
Define Database window, you can also click the Add Relationship 
button located at the bottom left of the window. 
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Managing an existing database 
Adding new records 
To add a new record to the database: 
• Click on the New Record button on the toolbar or choose New 

Record from the Records menu. 
 

 
 
• A new record will be added directly after the current record. 
 
Entering data in a new record 
• Enter data in the record’s first field. 
• Type the Tab key to move the flashing insertion point to the 

next field. 
 

 
 
• Type the Tab key to move from one field to the next until you 

have entered data in all of the appropriate fields in the record. 
 
Editing an existing record 
To edit a record that already exists in your database: 
• Using the Book tool, display the record you wish to edit. 
• Click on the field you wish to select it.  Once the field is 

selected, it can be edited like text in a Word document.   
 

 
 
• Repeat the previous steps to edit other records in your 

database. 
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Duplicating records 
To create an exact copy of a record: 
• Make sure that the record you wish to duplicate is being 

displayed in the FileMaker window.   
• Click on the Duplicate records button on the toolbar or choose 

Duplicate records from the Records menu. 
 

 
 

• The duplicate record will be added to the database and 
displayed in the FileMaker window. 

 
 
Deleting individual records 
To delete a single record from your database: 
• Display the record to be deleted in the FileMaker window. 
• Click on the Delete records button on the toolbar or choose 

Delete records from the Records menu. 
 

 
 

 
 
Deleting every record in your database 
To delete all the records in the database: 
• From the Records menu, select Delete all records.   
 
 
Tip: when a record is deleted from your database, it cannot be 
retrieved except from a backup copy of your database.  The delete 
command cannot be undone, so use it with caution. 
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Sorting records 
When retrieving data from your database, it is often useful to sort 
the data.  For example, a personnel database might be most useful 
when all of the records are sorted by employee last name.  Without 
such a sort order, FileMaker would display personnel records in 
the order in which they were created.  To sort the records in your 
database: 
• Click on the Sort button located on the toolbar. 
 

 
 

• The Sort Records window will appear. 
• Click on the name of the field you wish sort your records with. 
• Click on the button labeled >Move>. 

 

 
 
• Select the way you wish to sort your data: 

o To sort your data in ascending order, click on the radio 
button labeled Ascending order. 

o To sort your data in descending order, click on the radio 
button labeled Descending order. 
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• The name of your field will appear in the box labeled Sort 
Order  

 

 
 
• Click on the button labeled Sort.  
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Finding Records
FileMaker’s Find mode makes it easy to search for records in your 
database.  There are three ways to switch to the Find mode: 
• Click on the Find button located at the top of the Status Area. 
 

 
 
 
Simple Search 
To find records that match a single criterion (data found in a single 
field, for example): 
• Type your criterion in the appropriate field. 
• Click on the button labeled Find. 
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Printing Records 
FileMaker permits you to print a single record or multiple records, 
using any layout.  To print a single record: 

• Use the Book tool to display that record on the screen.   
• Click on the Print button located on the toolbar or select 

Print from the File menu.   
• In the Print dialog box, click on the button labeled Print. 

 
To print multiple records: 

• Search for the records that you wish to print, and display 
one of those records on the screen. 

• Click on the Print button on the toolbar or select Print 
from the File menu.   

• From the drop-down menu at the top of the Print dialog 
box, select Records Being Browsed. 

• Click on the button labeled Print. 
 

 
 
 
 
 
Planning a database 
A little planning goes a long way in creating a database that will be 
a useful and powerful tool for accomplishing your professional and 
organizational goals.  Be certain to take plenty of time to plan and 
test your database before you implement it and put it to work.  
Below are some ideas to consider in your planning process: 

• What is the goal of your project? 
• What is the goal of your database?  (Is it the same as the 

goal of your project?) 
• Who will use the database? 
• What kinds of information must be captured and made 

accessible? 
• What specific data do you want to track and manage? 
• How will you need to retrieve and output your data? 
• What fields will be necessary to capture the data? 

 
Tip: Consider creating a prototype of your database to be tested 
with a subset of your data.  This prototype will allow you to work 
with your database and your data so you can make necessary 
revisions. 
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