
 
 
 

FileMaker Pro 5: Basics 
Learning Guide 
 
 
 Database Basics 

A database, at its very core, is simply a structured collection of 
data.  Access sees your data in the form of a table that is composed 
of rows and columns.  Each of these rows is a record in your 
database, containing all of the data captured in your database about 
a single object, person, or concept.   
 
The sample table below captures information about CDs in an 
individual’s music collection.  The record displayed in the second 
row contains information about Blue Moon Swamp, a CD released 
in 1997 by John Fogerty. 
 
Tracking  Artist Album Name Released Location 
1 Farm Dogs Immigrant Sons 1998 Home 
2 John Fogerty Blue Moon Swamp 1997 Car 
3 Barenaked Ladies Stunt 1998 Office 
4 CPR CPR 1998 Home 
5 Elton John  Tumbleweed Connection 1971 Home 
6 Sting Bring on the Night 1985 Car 
7 Fleetwood Mac Rumours 1977 Home 
 
Every record is composed of fields, each of which contains a 
specific piece of data of a certain type (numbers, text, currency, 
dates, etc.).  Each field is represented as a column in a data table, 
because the field is present in each record in the database.  In this 
case, the Album Name field (shaded below) is a text field. 
 
Tracking  Artist Album Name Released Location 
1 Farm Dogs Immigrant Sons 1998 Home 
2 John Fogerty Blue Moon Swamp 1997 Car 
3 Barenaked Ladies Stunt 1998 Office 
4 CPR CPR 1998 Home 
5 Elton John  Tumbleweed Connection 1971 Home 
6 Sting Bring on the Night 1985 Car 
7 Fleetwood Mac Rumours 1977 Home 
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Once this structure is in place, you can access your data using 
different layouts to provide a greater level of flexibility in the 
display and organization of your data.  For example, you can enter 
data using forms, or create reports to present your data. 
 
 
 
Exploring the FileMaker interface 
The image below identifies the basic elements of FileMaker’s 
interface.  Each will be described in detail on the pages to follow. 
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Elements of the FileMaker window 
In addition to the standard window elements in Windows 95/98, 
FileMaker uses several graphic elements to provide its users with 
access to the data in a database as well as some basic commands. 

• Control strip 
 

 
 

The control strip, located at the left edge of the FileMaker 
window, provides the capability to browse database records 
and select layouts with which to display data. 
 

• The Rolodex tool 
 

 
 

This tool, located at the top of the control strip, provides 
browsing access to the records within a database.  The 
number at the lower right of the Rolodex icon shows the 
number of the record currently displayed in the FileMaker 
window.  The lines that may be displaying on the upper or 
lower Rolodex card indicate that records exist prior to or 
after the record that is currently displayed.  To display the 
next record in the database, click on the lower card on the 
Rolodex icon.  To display the previous record, click on the 
upper card.   
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• The layout drop menu 
 

 
 

This menu, displayed above the Rolodex icon, provides 
access to the various layouts that may have been created 
for your database.  Each layout displays all of part of your 
data using a different graphic design that has been 
developed for easy data retrieval.  The name of the 
currently active layout is displayed above the Rolodex icon, 
and is marked with a checkmark in the layout menu.  To 
switch layouts, simply click on the name of the current 
layout to display the menu, then click on the name of the 
desired layout in the layout menu. 
 

• The mode pop-up menu 
 

 
 

This menu, displayed at the bottom left of the FileMaker 
window, makes it easy to switch between FileMaker’s 
modes: 

o Browse: this mode permits entry and retrieval of 
data 

o Find: this mode permits searching of a database 
o Layout: this mode provides tools for creating 

custom layouts 
o Preview: this mode serves as a Page Preview 

function. 
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• The toolbar 
 

 
 

This window element, a new feature in FileMaker 5.0, 
provides easy access to many of the basic commands for 
working with databases: 
 

 New database Create a new database 
file 

 Open database Open an existing 
database 

 Print records Print some or all 
records in the database 

 Add record Add a new record to 
the database 

 Duplicate records 
Create a copy of the 
record displaying on 
the screen 

 Delete record 
Delete the record 
displaying on the 
screen 

Sort records Sort records in the 
database 

 
 

• Magnification buttons 
 

 
 

These buttons, located at the bottom of the grey control 
strip at the left of the FileMaker window, allow you to view 
your database at greater or lesser magnification.  To zoom 
in on your data layout, click on the right-hand button; to 
zoom out, click on the middle button.  Clicking on the 
button labeled 100 will return the layout to normal 
magnification. 
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• Control strip toggle button 
 

 
 
Clicking on this button, located at the bottom right of the 
control strip, will hide the control strip.  Clicking again on 
this button will restore the control strip to view. 
 
 
 

FileMaker Views 
FileMaker offers 3 different ways to view the data in your 
database.  You can toggle between views at will by selecting your 
desired view from the View menu.  Bear in mind that these views 
are merely different ways of displaying data – the data in your 
database will not be changed when it is displayed in a different 
view. 

o View as form:  This command displays a single record on 
the screen at a time, using the selected layout. 

o View as list:  This command displays multiple records on 
the screen at a time, using the selected layout.  Note that the 
length of your layout will determine how many records will 
display on the screen at the time; shorter layouts will permit 
the display of more records at once. 

o View as table:  This command displays your data in a table 
format, using one row to represent each record.  Each field 
is represented as a column in the table. 
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Creating a new database 
• From the File menu, choose New Database. 
• Using the Create New File window, navigate to the folder 

in which you want to save your new database.  In the File 
name box, type a name for the database.  Click on Save. 

 

 
 
 
Defining fields for your database 

• After creating a database, define the fields that will capture 
your data. 

o In the Define Fields window, type the name of the 
new field in the Field Name box. 

o Click on the radio button next to the type of data 
that you wish to store in this field. 

o Click on Create to add the new field to the 
database. 
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• To define a second field, first delete the name of your 
first field by typing delete.  Next, type the name of the new 
field, select its type, and click on Create. 

• Define additional fields using these steps. 
• To change the name or data type of an existing field before 

entering data: 
o Click on the field’s name in the field list in the 

middle of the Define Fields window.   
o Once the field name is highlighted in blue, make 

changes to the field name or type. 
o Click Save to finalize the changes to the field. 

 

 
 

• When you have finished defining your fields, click Done. 
• FileMaker will automatically create an initial blank record 

in your database and make the first field in the record 
active for data entry. 

 
Field Type Field Content Restrictions 
Text Text of any kind Limited to 64,000 characters 
Number Numeric content Limited to 255 characters; must be on one 

line 
Date Full date in various 

formats 
Single date between year 1 and year 5000; 
limited to 8 characters (month, day, year, 
separators) 

Time Clock time One time; limited to 8 characters 
Container Image, movie, 

sound, or linked 
object 

Limited to one item per container field 

Calculation Result of a formula-
based calculation 

Limited to one formula with a text, numeric, 
date, time, or container result 

Summary Summation of fields 
in several records 

Result of a single summary function 
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Managing an existing database 
 
Adding new records 
To add a new record to the database, click on the New Record 
button on the toolbar or choose New Record from the Records 
menu. 
 

 
 
FileMaker will add a new record to your database immediately 
following the record that was previously displaying; this new 
record will be displayed on the screen for data entry. 
 
 
Entering data in a new record 

• Enter data in the record’s first field, then type the Tab key 
to move the flashing insertion point to the next field. 

 

 
 

• Use the Tab key to move from one field to the next until 
you have entered data in all of the appropriate fields in the 
record. 

 
Editing an existing record 
To edit a record that already exists in your database, use the 
Rolodex tool to display that record on the screen.  Select the field 
to be edited by clicking on it.   

• Once the field is selected, a black border will appear 
around the text in that field and a flashing cursor will 
appear inside the field.  The fields that are not active will 
display gray borders. 

 

 
 

• After the field has been selected, text inside that field can 
be edited as if it were in a Word document. 

• To edit another field within the same record, use the tab 
key to move forward to another field.  The shift-tab key 
combination can be used to move back to a previous field. 
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Duplicating records 
At times, a new record in a database will be similar in many 
respects to an existing record.  In this situation, the easiest way to 
add the new record is to duplicate the existing similar record and 
then make the necessary changes to the duplicate.  To create an 
exact copy of a record, first make sure that the record you wish to 
duplicate is being displayed in the FileMaker window.  Next, click 
on the Duplicate records button on the toolbar or choose 
Duplicate records from the Records menu. 
 

 
 
The duplicate record will be added to the database and displayed in 
the FileMaker window. 
 
 
Deleting individual records 
To delete a single record from your database, first display the 
record to be deleted in the FileMaker window.  To delete the 
record, click on the Delete records button on the toolbar or choose 
Delete records from the Records menu. 
 

 
 
 
Deleting every record in your database 
To delete all the records in the database, choose Delete all records 
from the Records menu.  Note: when a record is deleted from 
your database, it cannot be retrieved except from a backup copy of 
your database.  The delete command cannot be undone, so use it 
with care. 
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Sorting records 
When retrieving data from your database, it is often useful to sort 
that data.  For example, a personnel database might be most useful 
when all of the records are sorted by employee last name.  Without 
such a sort order, FileMaker would display personnel records in 
the order in which they were created.  To sort the records in your 
database, click on the Sort button on the toolbar or choose Sort 
from the Records menu. 
 

 
 

Next, FileMaker will display a dialog box that allows a custom sort 
order to be created.  This dialog box contains two lists of fields: 

• all of the fields in your database (on the left) 
• the fields to use for sorting (on the right) 

 

 
 
To sort the records in your database using the contents of one field 
(for example, to sort your CD database by Artist), click on the 
name of that field in the left-hand field list and click on the Move 
button.  FileMaker will display the field’s name in the Sort Order 
box on the right side of the Sort Records dialog box.  Next, you 
can elect to sort your database in the following ways: 

• Ascending order; with this order, the first record in the 
database will be the one with the smallest value in the 
selected field.  When sorting using a text field, ascending 
order is alphabetical order. 

Descending order; with this order, the first record in the database 
will be the one with the largest value in the selected field.  When 
sorting using a text field, descending order is reverse alphabetical 
order. 
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Finding Records 
FileMaker’s Find mode makes it easy to search for records in your 
database.  To switch to the Find mode, use the Mode pop-up menu 
at the bottom of the FileMaker window or select Find mode from 
the View menu.  FileMaker will then display an empty record, 
using the most recent layout.  (To switch to a different layout, 
simply choose the layout by name using the Layout drop-down 
menu above the Rolodex tool.) 
 
 
Simple Search 
To find records that match a single criterion (data found in a single 
field, for example): 

• Type your criterion in the appropriate field. 
• Click Find. 
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Printing Records 
FileMaker permits you to print a single record or multiple records, 
using any layout.  To print a single record: 

• Use the Rolodex tool to display that record on the screen.   
• Next, click on the Print button on the toolbar or choose 

Print from the File menu.   
• Finally, in the Print dialog box, click on the Print button. 

 
To print multiple records: 

• Search for the records that you wish to print, and display 
one of those records on the screen. 

• Next, click on the Print button on the toolbar or choose 
Print from the File menu.   

• From the drop-down menu at the top of the Print dialog 
box, select records being browsed, and click Print. 

 

 
 
 
 
Planning a database 
A little planning goes a long way in creating a database that will be 
a useful and powerful tool for accomplishing your professional and 
organizational goals.  Be certain to take plenty of time to plan and 
test your database before you implement it and put it to work.  
Below are some ideas to consider in your planning process: 

• What is the goal of your project? 
• What is the goal of your database?  (Is it the same as the 

goal of your project?) 
• Who will use the database? 
• What kinds of information must be captured and made 

accessible? 
• What specific data do you want to track and manage? 
• How will you need to retrieve and output your data? 
• What fields will be necessary to capture the data? 

 
Tip: Consider creating a prototype of your database to be tested 
with a subset of your data.  This prototype will allow you to 
actually work with your database and your data so that you can 
make necessary revisions before implementing your database in a 
mission-critical situation. 
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