
 
 
 

Excel 2003: Formatting 
Learning Guide 
 
 
 Excel design concepts  

 
The Goal 
Your goal is always to design a clean and readable spreadsheet by: 

• Enhancing and emphasizing your data where appropriate 
• Creating contrast between the various sections of your 

spreadsheet: 
o document title 
o column headers 
o row headers 
o data of different kinds 

 
The Tools 
Use these tools to create contrast and emphasis in your documents.   

• colors 
• borders 
• fonts 
• text styles  

Use no more than two fonts in your document.  To create contrast 
within data using a single font, use text styles like bolding and 
italicizing.  Most documents will use these two kinds of fonts in 
combination: 
• A serif font (like Times, shown below, left) for text in your 

spreadsheet.   
• A sans serif font (like Tahoma, shown below, right) for your 

titles and headers.   
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The Rules 
• Don’t use too many fonts in your spreadsheet.   
• Only use color only if you’ll print or display your spreadsheet 

on a color device; otherwise, use black and white shading 
instead. 

• Use color, borders, and styles conservatively, unless your 
audience demands radical design.   

• Let your design enhance the presentation of your data, not 
overwhelm it. 

• Only create a design element that has a purpose.  Don’t 
simply create one because it looks cool. 

• Know when to break the rules.   
 
 
 
Formatting Cells 
 
Applying text formats 

• Select the cells to receive the new text formatting.  
• From the Format menu, choose Cells.  
• Click on the Font tab. 

 

 
 

• To change basic text attributes: 
o Click on the name of the font you wish to use. 
o Click on the name of the font style you want. 
o Click on the font size you wish to use. 
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• To add or change the underlining in the selected cells, click 
on the down-facing arrow next to the Underline box. 

• From the Underline drop-down menu, select the underline 
style that you wish. 

 

 
 

• To change the color of your text, click on the down-facing 
arrow next to the Color box. 

• From the Color drop-down menu, select the text color that 
you wish. 

 

 
 
Tip: Removing all font formatting 
To remove all font formatting, click to place a check mark in the 
Normal font checkbox in the Format Cells window’s Font tab.  
This will return the text in the selected cell or cell range to your 
default font and style. 
 

 
 
 
Tip: Applying existing formats to unformatted cells 

• Select the formatted cell (or cell range). 
• Click on the Format Painter button on the standard 

toolbar. 
 

 
 

• Click on an unformatted cell (or drag across an 
unformatted cell range) to apply the formatting. 
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All about number formats 
Excel permits numbers to be formatted in many different ways.  
Without changing the value of the number in a cell, number 
formats allow numbers to be represented so that they can be used 
in many different kinds of projects. 
 
Applying number formats 

• Select the cells containing your number(s).  
• From the Format menu, choose Cells.  
• Click on the Number tab. 
• From the list of categories, select the number format that is 

best suited to your project.   
• Use the Sample box to decide whether the format you 

chose best represents your number. 
 

 
 

• To learn more about some common number formats, use 
the table below. 

 
Category Looks like…. Options 
General 0.33 None 
Number 0.33 Number of decimal places 

shown, negative number format 
Currency $0.33 Number of decimal places 

shown, currency symbol, 
negative number format 

Accounting $0.33 (lines up 
decimal points in a 
column of data) 

Number of decimal places 
shown, currency symbol 

Percentage 33% Number of decimal places 
shown 

Fraction 1/3 Number of digits in 
denominator, type of fraction 

Text 0.33 Number is displayed exactly as 
entered 

Date 1/1/00 Several date formats available 
Time 15:30; 1:30 pm; etc. Several time formats available 
Special Varies Zip code, phone number, social 

security number 
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Applying a basic cell border 
Borders can provide contrast, serving to highlight cells containing 
important data.  To create a border around one cell or a group of 
cells: 

• Select the cells to receive the new border formatting.  
• From the Format menu, choose Cells.  
• Click on the Borders tab. 

 

 
 

• To add a basic border outside the selected cell range, 
click on the Outline button. 

• To add borders between cells within the selected cell range, 
click on the Inside button. 

• Click OK. 
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Applying a custom cell border 
• To add a custom border, first choose a style for your 

border.   
• In the Style box at the right side of the Format Cells 

window, click on the line style you want for your cell 
border. 

• Click on the down-facing arrow next to the Color box to 
display the Color menu.  Click on the color that you want 
for your border. 

• Click on the buttons in the Border area of the Format 
Cells window to add sections of the cell border using the 
style and color you selected.  Click OK to apply your 
custom border to the selected cell range. 

 

 
 
 
 
Applying cell background colors 
Background colors (called patterns in Excel) can provide 
additional contrast in your worksheets, whether you use them by 
themselves or to complement existing cell borders.  To apply a 
background color: 

• Select the cells to receive the new background color.  
• From the Format menu, choose Cells.  
• Click on the Patterns tab. 
• Click on the square containing the color you wish to use as 

the background to the selected cell or cells. 
• Click OK to apply this new background color to your cells. 
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Applying text alignment formatting 
• Select the cells to receive the new formatting.  
• From the Format menu, choose Cells.  
• Click on the Alignment tab. 
• Click on the drop-down arrow next to the Horizontal box 

to display a drop-down menu of horizontal alignment 
options. 

 

 
 

• Click OK to apply the alignment formatting to text within 
the selected cells. 

 
 
 
Formatting long text phrases within a cell  
In many situations, the line of text you enter in a cell will be wider 
than the cell itself.  In these situations, the text may be hidden 
beyond the edge of the cell.  Although one solution to this problem 
is to resize the cell, there are two additional solutions: shrinking 
the text to fit the cell, and wrapping the text so that it displays on 
multiple lines within the cell. 

• Select the cells to receive the new formatting.  
• From the Format menu, choose Cells.  
• Click on the Alignment tab and go to the Text control area 

of the Format Cells window. 
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• To shrink the text, click in the Shrink to fit box. 
• To wrap text within the cell, click in the Wrap text box. 

 

 
 
 
Merging cells 
Another solution for handling long text phrases is to merge several 
cells together so that the text can be fully displayed.  To merge 
several cells: 

• Select the cells to be merged. 
• From the Format menu, choose Cells.  
• Click on the Alignment tab. 
• In the Text control area, click in the Merge cells box. 

 
 
 
Applying conditional formatting 
Excel’s conditional formatting can apply specific formatting to 
highlight cells in your worksheet that meet a certain condition.  To 
set up conditional formatting: 

• Select the cells that you wish to conditionally format. 
• From the Format menu, choose Conditional Formatting. 

 

 
 

• Next, specify the condition that will trigger your 
formatting. 
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• Click on the second down-facing arrow from the left to 
display the operators menu.  Select the operator that you 
want. 

 

 
 

• Next, enter the condition (or conditions) that will trigger 
the formatting.  In the example below, any selected cell 
whose value is greater than 10 will receive special 
formatting. 

 

 
 

• Finally, click on the Format button to specify the 
formatting that will be applied to cells that meet your 
condition.  You’ll be able to apply special font formatting, 
borders, and colors to these cells. 

• When you have finished selecting your formatting, click 
OK to close the Format Cells window.  Click OK again to 
apply the conditional formatting to your cells. 
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Creating headers and footers 
Like Word, Excel allows you to add headers and footers to your 
spreadsheet.  Headers can sometimes serve as appropriate locations 
for spreadsheet titles, while footers can contain useful document or 
page information that isn’t found elsewhere in your spreadsheet. 
 
 
Choosing a predefined header 

• From the View menu, choose Header and Footer. 
• In the Page Setup window, click on the Header/Footer tab 

to bring it to the foreground. 
 

 
 

• Click on the down-facing arrow next to the Header box to 
display a menu of predefined headers that can be added to 
your document.  Click to select the header that you prefer. 
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Choosing a pre-defined footer 
• From the View menu, choose Header and Footer. 
• In the Page Setup window, click on the Header/Footer tab 

to bring it to the foreground. 
• Click on the down-facing arrow next to the Footer box to 

display a menu of predefined footers that can be added to 
your document.  Click to select the footer that you prefer. 

 

 
 
Tip: To remove a header or footer that you have chosen, choose 
(none) from the top of the header menu or the footer menu. 
 
 
 
Creating a custom header 

• From the Header/Footer tab of the Page Setup window, 
click on Custom Header. 

• To add left-justified text to your header, type the text in the 
Left section box. 

• To add centered text to your header, type in the Center 
section box. 

• To add right-justified text to your header, type in the Right 
section box. 

 

 
 

• To format text in any of the header sections, drag to select 
the text, and click on the Format Text button. 
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• From the Font window that appears, select the text 
formatting that you wish, and click OK. 

 

 
 

• Click on any of the buttons in the middle of the Header 
window to insert additional information in your custom 
header. 

 
Inserts the current page number 

Inserts the number of pages in the spreadsheet 

Inserts the current date 

Inserts the current time 

Inserts the name of the spreadsheet 

Inserts the name of the current worksheet 

 
 

Creating a custom footer 
• From the Header/Footer tab of the Page Setup window, 

click on Custom Footer. 
• To create your custom footer, use the same techniques that 

you used when creating your custom header. 
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Freezing panes in your worksheet 
In many situations, the length or width of your worksheets will 
make it impossible for your column or row headers to be always in 
view.  However, once these headers disappear from view, it’s often 
difficult to be able to work with the data that is visible on your 
screen.  In these situations, Excel allows you to freeze rows and/or 
columns in your spreadsheet to keep those useful data headers 
visible: 

• A horizontal freeze will keep one or more rows always in 
view at the top of your worksheet as you scroll up and 
down. 

• A vertical freeze will keep one or more columns always in 
view at the left of your worksheet as you scroll left and 
right. 

 
 
Inserting a horizontal freeze 

• Decide which row or rows you wish to constantly display at 
the top of your worksheet when changing or adding data. 

• Click on the header of the row below the one (or ones) to 
be constantly displayed. 

o Remember that a horizontal freeze will always be 
inserted above the row that you select. 

o For example, if I wish to make sure that my 
worksheet’s column headers in row 1 are always 
displaying, I’ll first click on the header for row 2 to 
select that row. 
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• From the Window menu, select Freeze panes. 
 

 
 

• Excel will insert a horizontal freeze in your spreadsheet 
above the row that you selected. 

• To deselect this row, click on any cell elsewhere in your 
spreadsheet. 

• To remind you that you have frozen a pane within your 
spreadsheet, Excel will mark the lower edge of the frozen 
area with a thin black border. 

o Any cells above the border will be continuously 
displayed as you scroll up and down on your 
worksheet. 

 
 
Removing an existing freeze 

• From the Window menu, choose Unfreeze panes. 
 
 
Inserting a vertical freeze 

• Decide which column or columns you wish to constantly 
display at the left of your worksheet when changing or 
adding data. 

• Click on the header of the column to the right of the one 
(or ones) to be constantly displayed. 

o Remember that a vertical freeze will always be 
inserted to the left of the column that you select. 

• From the Window menu, select Freeze panes. 
• Excel will insert a vertical freeze in your spreadsheet to the 

left of the column that you selected. 
• To deselect the column to the right of your freeze, click on 

any cell outside the selected column. 
• To remind you that you have frozen a pane within your 

spreadsheet, Excel will mark the right edge of the frozen 
area with a thin black border. 
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Inserting a combined horizontal and vertical freeze 
In most cases, you’ll insert a combined freeze when you wish to 
constantly display both your custom column and custom row 
headers when editing your worksheet.   

• Find the cell at which your row of column headers and your 
column of row headers intersect. 

• Click in the cell to the lower right of this cell. 
o For example, in most cases, your column headers 

will be in Row 1 and your row headers will be in 
Column A.  Therefore, you’ll want to insert a freeze 
to make sure that both Row 1 and Column A are 
constantly displayed. Since Row 1 and Column A 
intersect at cell A1, click in cell B2 — the cell to the 
bottom right of cell A1. 

• From the Window menu, select Freeze panes. 
 

 
 

• Excel will insert a vertical freeze in your spreadsheet to the 
left of the cell that you selected, and a horizontal freeze 
above the cell that you selected. 

o In the example above, Excel will insert a combined 
freeze so that Row 1 (the row above cell B2) and 
Column A (the column to the left of cell B2) will be 
constantly displayed.   

• To remind you that you have frozen a pane within your 
spreadsheet, Excel will mark the right edge of the frozen 
vertical area and the bottom edge of the frozen horizontal 
area with a thin black border. 
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